Exploit/Advisories no image

Published on May 22nd, 2024 📆 | 8094 Views ⚑

0

Ubuntu Security Notice USN-6777-3 – Torchsec


iSpeech

==========================================================================
Ubuntu Security Notice USN-6777-3
May 21, 2024

linux-gcp vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 LTS

Summary:

Several security issues were fixed in the Linux kernel.

Software Description:
- linux-gcp: Linux kernel for Google Cloud Platform (GCP) systems

Details:

Zheng Wang discovered that the Broadcom FullMAC WLAN driver in the Linux
kernel contained a race condition during device removal, leading to a use-
after-free vulnerability. A physically proximate attacker could possibly
use this to cause a denial of service (system crash). (CVE-2023-47233)





Several security issues were discovered in the Linux kernel.
An attacker could possibly use these to compromise the system.
This update corrects flaws in the following subsystems:
- Block layer subsystem;
- Userspace I/O drivers;
- Ceph distributed file system;
- Ext4 file system;
- JFS file system;
- NILFS2 file system;
- Bluetooth subsystem;
- Networking core;
- IPv4 networking;
- IPv6 networking;
- Logical Link layer;
- MAC80211 subsystem;
- Netlink;
- NFC subsystem;
- Tomoyo security module;
(CVE-2023-52524, CVE-2023-52530, CVE-2023-52601, CVE-2023-52439,
CVE-2024-26635, CVE-2023-52602, CVE-2024-26614, CVE-2024-26704,
CVE-2023-52604, CVE-2023-52566, CVE-2021-46981, CVE-2024-26622,
CVE-2024-26735, CVE-2024-26805, CVE-2024-26801, CVE-2023-52583)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 LTS
linux-image-4.15.0-1162-gcp 4.15.0-1162.179~16.04.1
Available with Ubuntu Pro
linux-image-gcp 4.15.0.1162.179~16.04.1
Available with Ubuntu Pro
linux-image-gke 4.15.0.1162.179~16.04.1
Available with Ubuntu Pro

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

References:
https://ubuntu.com/security/notices/USN-6777-3
https://ubuntu.com/security/notices/USN-6777-1
CVE-2021-46981, CVE-2023-47233, CVE-2023-52439, CVE-2023-52524,
CVE-2023-52530, CVE-2023-52566, CVE-2023-52583, CVE-2023-52601,
CVE-2023-52602, CVE-2023-52604, CVE-2024-26614, CVE-2024-26622,
CVE-2024-26635, CVE-2024-26704, CVE-2024-26735, CVE-2024-26801,
CVE-2024-26805

Source link

Tagged with:



Comments are closed.