Exploit/Advisories no image

Published on May 9th, 2024 📆 | 1859 Views ⚑

0

Ubuntu Security Notice USN-6768-1 – Torchsec


iSpeech.org

==========================================================================
Ubuntu Security Notice USN-6768-1
May 09, 2024

glib2.0 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 24.04 LTS
- Ubuntu 23.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

GLib could be made to accept spoofed D-Bus signals.

Software Description:
- glib2.0: GLib library of C routines

Details:

Alicia Boya García discovered that GLib incorrectly handled signal
subscriptions. A local attacker could use this issue to spoof D-Bus signals
resulting in a variety of impacts including possible privilege escalation.

Update instructions:





The problem can be corrected by updating your system to the following
package versions:

Ubuntu 24.04 LTS
libglib2.0-0t64 2.80.0-6ubuntu3.1
libglib2.0-bin 2.80.0-6ubuntu3.1

Ubuntu 23.10
libglib2.0-0 2.78.0-2ubuntu0.1
libglib2.0-bin 2.78.0-2ubuntu0.1

Ubuntu 22.04 LTS
libglib2.0-0 2.72.4-0ubuntu2.3
libglib2.0-bin 2.72.4-0ubuntu2.3

Ubuntu 20.04 LTS
libglib2.0-0 2.64.6-1~ubuntu20.04.7
libglib2.0-bin 2.64.6-1~ubuntu20.04.7

After a standard system update you need to reboot your computer to make all
the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6768-1
CVE-2024-34397

Package Information:
https://launchpad.net/ubuntu/+source/glib2.0/2.80.0-6ubuntu3.1
https://launchpad.net/ubuntu/+source/glib2.0/2.78.0-2ubuntu0.1
https://launchpad.net/ubuntu/+source/glib2.0/2.72.4-0ubuntu2.3
https://launchpad.net/ubuntu/+source/glib2.0/2.64.6-1~ubuntu20.04.7

Source link

Tagged with:



Leave a Reply

Your email address will not be published.