Exploit/Advisories no image

Published on September 15th, 2023 📆 | 3302 Views ⚑

0

Ubuntu Security Notice USN-6373-1 – Torchsec


iSpeech

==========================================================================
Ubuntu Security Notice USN-6373-1
September 14, 2023

gawk vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)
- Ubuntu 14.04 LTS (Available with Ubuntu Pro)

Summary:

gawk could be made to crash if it received specially crafted
input.

Software Description:
- gawk: GNU awk, a pattern scanning and processing language

Details:

It was discovered that gawk could be made to read out of bounds when
processing certain inputs. If a user or an automated system were tricked
into opening a specially crafted input, an attacker could possibly use
this issue to cause a denial of service.

Update instructions:





The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
gawk 1:5.1.0-1ubuntu0.1

Ubuntu 20.04 LTS:
gawk 1:5.0.1+dfsg-1ubuntu0.1

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
gawk 1:4.1.4+dfsg-1ubuntu0.1~esm1

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
gawk 1:4.1.3+dfsg-0.1ubuntu0.1~esm1

Ubuntu 14.04 LTS (Available with Ubuntu Pro):
gawk 1:4.0.1+dfsg-2.1ubuntu2+esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6373-1
CVE-2023-4156

Package Information:
https://launchpad.net/ubuntu/+source/gawk/1:5.1.0-1ubuntu0.1
https://launchpad.net/ubuntu/+source/gawk/1:5.0.1+dfsg-1ubuntu0.1

Source link

Tagged with: β€’ β€’ β€’ β€’



Leave a Reply

Your email address will not be published.