Exploit/Advisories no image

Published on September 16th, 2023 📆 | 7071 Views ⚑

0

Ubuntu Security Notice USN-6371-1 – Torchsec


iSpeech.org

==========================================================================
Ubuntu Security Notice USN-6371-1
September 14, 2023

libssh2 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)
- Ubuntu 14.04 LTS (Available with Ubuntu Pro)

Summary:

libssh2 could be made to crash if it received specially
crafted network traffic.

Software Description:
- libssh2: Client-side C library implementing the SSH2 protocol

Details:

It was discovered that libssh2 incorrectly handled memory
access. An attacker could possibly use this issue to cause
a crash.

Update instructions:





The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
libssh2-1 1.8.0-2.1ubuntu0.1

Ubuntu 18.04 LTS:
libssh2-1 1.8.0-1ubuntu0.1

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
libssh2-1 1.5.0-2ubuntu0.1+esm2

Ubuntu 14.04 LTS (Available with Ubuntu Pro):
libssh2-1 1.4.3-2ubuntu0.2+esm3

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6371-1
CVE-2020-22218

Package Information:
https://launchpad.net/ubuntu/+source/libssh2/1.8.0-2.1ubuntu0.1
https://launchpad.net/ubuntu/+source/libssh2/1.8.0-1ubuntu0.1

Source link

Tagged with: β€’ β€’ β€’ β€’



Leave a Reply

Your email address will not be published.