Exploit/Advisories no image

Published on May 23rd, 2023 📆 | 4890 Views ⚑

0

Ubuntu Security Notice USN-5725-2 – Torchsec


Text to Speech Demo

==========================================================================
Ubuntu Security Notice USN-5725-2
May 23, 2023

golang-1.13 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 LTS (Available with Ubuntu Pro)

Summary:

Go applications could be made to hang or crash if they received
specially crafted input.

Software Description:
- golang-1.13: Go programming language compiler

Details:

USN-5725-1 fixed a vulnerability in Go. This update provides
the corresponding update for Ubuntu 16.04 LTS.





Original advisory details:

Diederik Loerakker, Jonny Rhea, Raúl Kripalani, and Preston
Van Loon discovered that Go incorrectly handled certain inputs.
An attacker could possibly use this issue to cause Go applications
to hang or crash, resulting in a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
golang-1.13 1.13.8-1ubuntu1~16.04.3+esm2
golang-1.13-go 1.13.8-1ubuntu1~16.04.3+esm2
golang-1.13-src 1.13.8-1ubuntu1~16.04.3+esm2

In general, a standard system update will make all the necessary changes.
You still need to update all packages built with the affected version.

References:
https://ubuntu.com/security/notices/USN-5725-2
https://ubuntu.com/security/notices/USN-5725-1
CVE-2020-16845

Source link

Tagged with:



Comments are closed.