Exploit/Advisories no image

Published on June 7th, 2024 📆 | 7267 Views ⚑

0

Red Hat Security Advisory 2024-3708-03 – Torchsec


iSpeech.org

The following advisory data is extracted from:

https://access.redhat.com/security/data/csaf/v2/advisories/2024/rhsa-2024_3708.json

Red Hat officially shut down their mailing list notifications October 10, 2023. Due to this, Packet Storm has recreated the below data as a reference point to raise awareness. It must be noted that due to an inability to easily track revision updates without crawling Red Hat's archive, these advisories are single notifications and we strongly suggest that you visit the Red Hat provided links to ensure you have the latest information available if the subject matter listed pertains to your environment.

- Packet Storm Staff

====================================================================
Red Hat Security Advisory

Synopsis: Important: Red Hat Build of Apache Camel 3.20.6 for Spring Boot security update.
Advisory ID: RHSA-2024:3708-03
Product: Red Hat Build of Apache Camel
Advisory URL: https://access.redhat.com/errata/RHSA-2024:3708
Issue date: 2024-06-06
Revision: 03
CVE Names: CVE-2022-34169
====================================================================

Summary:

Red Hat build of Apache Camel 3.20.6 for Spring Boot release and security update is now available.

Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

Description:

Red Hat build of Apache Camel 3.20.6 for Spring Boot release and security update is now available.

The purpose of this text-only errata is to inform you about the security issues fixed.

Security Fix(es):





* xalan: OpenJDK: integer truncation issue in Xalan-J (JAXP, 8285407) (CVE-2022-34169)

* jettison: stack overflow in JSONObject() allows attackers to cause a Denial of Service (DoS) via crafted JSON data (CVE-2022-45685)

* santuario: Private Key disclosure in debug-log output (CVE-2023-44483)

* springframework: URL Parsing with Host Validation (CVE-2024-22262)

* cxf-core: Apache CXF SSRF Vulnerability using the Aegis databinding (CVE-2024-28752)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution:

https://access.redhat.com/articles/11258

CVEs:

CVE-2022-34169

References:

https://access.redhat.com/security/updates/classification/#important
https://bugzilla.redhat.com/show_bug.cgi?id=2108554
https://bugzilla.redhat.com/show_bug.cgi?id=2214825
https://bugzilla.redhat.com/show_bug.cgi?id=2246070
https://bugzilla.redhat.com/show_bug.cgi?id=2270732
https://bugzilla.redhat.com/show_bug.cgi?id=2275257

Source link

Tagged with:



Leave a Reply

Your email address will not be published.