Exploit/Advisories no image

Published on June 5th, 2024 📆 | 5438 Views ⚑

0

Red Hat Security Advisory 2024-3560-03 – Torchsec


TTS

The following advisory data is extracted from:

https://access.redhat.com/security/data/csaf/v2/advisories/2024/rhsa-2024_3560.json

Red Hat officially shut down their mailing list notifications October 10, 2023. Due to this, Packet Storm has recreated the below data as a reference point to raise awareness. It must be noted that due to an inability to easily track revision updates without crawling Red Hat's archive, these advisories are single notifications and we strongly suggest that you visit the Red Hat provided links to ensure you have the latest information available if the subject matter listed pertains to your environment.

- Packet Storm Staff

====================================================================
Red Hat Security Advisory

Synopsis: Important: Red Hat JBoss Enterprise Application Platform 7.4.17 Security update
Advisory ID: RHSA-2024:3560-03
Product: Red Hat JBoss Enterprise Application Platform
Advisory URL: https://access.redhat.com/errata/RHSA-2024:3560
Issue date: 2024-06-03
Revision: 03
CVE Names: CVE-2021-23445
====================================================================

Summary:

An update is now available for Red Hat JBoss Enterprise Application Platform 7.4 for Red Hat Enterprise Linux 8.
Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

Description:

Red Hat JBoss Enterprise Application Platform 7 is a platform for Java applications based on the WildFly application runtime. This release of Red Hat JBoss Enterprise Application Platform 7.4.17 serves as a replacement for Red Hat JBoss Enterprise Application Platform 7.4.16, and includes bug fixes and enhancements. See the Red Hat JBoss Enterprise Application Platform 7.4.17 Release Notes for information about the most significant bug fixes and enhancements included in this release.

Security Fix(es):





* cxf-core: Apache CXF SSRF Vulnerability using the Aegis databinding
[eap-7.4.z] (CVE-2024-28752)

* eap: JBoss EAP: wildfly-elytron has a SSRF security issue [eap-7.4.z]
(CVE-2024-1233)

* datatables.net: contents of array not escaped by HTML escape entities function
[eap-7.4.z] (CVE-2021-23445)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution:

CVEs:

CVE-2021-23445

References:

https://access.redhat.com/security/updates/classification/#important
https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/7.4/
https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/7.4/html-single/installation_guide/
https://bugzilla.redhat.com/show_bug.cgi?id=2257732
https://bugzilla.redhat.com/show_bug.cgi?id=2270732
https://issues.redhat.com/browse/JBEAP-25637
https://issues.redhat.com/browse/JBEAP-25786
https://issues.redhat.com/browse/JBEAP-26406
https://issues.redhat.com/browse/JBEAP-26439
https://issues.redhat.com/browse/JBEAP-26680
https://issues.redhat.com/browse/JBEAP-26692
https://issues.redhat.com/browse/JBEAP-26705
https://issues.redhat.com/browse/JBEAP-26718
https://issues.redhat.com/browse/JBEAP-26782
https://issues.redhat.com/browse/JBEAP-26815
https://issues.redhat.com/browse/JBEAP-26824
https://issues.redhat.com/browse/JBEAP-26828
https://issues.redhat.com/browse/JBEAP-26922
https://issues.redhat.com/browse/JBEAP-26944
https://issues.redhat.com/browse/JBEAP-26959

Source link

Tagged with:



Leave a Reply

Your email address will not be published.