Pentest Tools no image

Published on February 9th, 2015 📆 | 7217 Views ⚑

0

Droopescan – Plugin Based CMS Security Scanner


https://www.ispeech.org/text.to.speech
Droopescan is a plugin-based CMS security scanner that that will help you with identifying issues with several CMSs, mainly Drupal & Silverstripe.

Droopescan aims to be the most accurate by default, while not overloading the target server due to excessive concurrent requests. Due to this, by default, a large number of requests will be made with four threads; change these settings by using the –number and –threads arguments respectively.

[adsense size='1']

 

Droopescan is able to perform four kinds of tests:

  • Plugin checks: Performs several thousand HTTP requests and returns a listing of all plugins found to be installed in the target host.
  • Theme checks: As above, but for themes.
  • Version checks: Downloads several files and, based on the checksums of these files, returns a list of all possible versions.
  • Interesting url checks: Checks for interesting urls (admin panels, readme files, etc.)

Installation

Installation is easy using pip:

Manual installation is as follows:

The master branch corresponds to the latest release (what is in pypi). Development branch is unstable and all pull requests must be made against it.

You can download Droopescan following the instructions above or read more here.

Tagged with:



Leave a Reply

Your email address will not be published.